MVN

io.github.fvarrui : javapackager

Maven & Gradle

Jul 18, 2022
441 stars

javapackager · Hybrid Maven/Gradle plugin to package Java applications as native Windows, Mac OS X or GNU/Linux executables and create installers for them

<dependency>
    <groupId>io.github.fvarrui</groupId>
    <artifactId>javapackager</artifactId>
    <version>1.6.7</version>
</dependency>
Copy
pom.xml
Table Of Contents

Latest Version

Choose a version of io.github.fvarrui : javapackager to add to Maven or Gradle - Latest Versions:

  • Latest Stable: 1.6.7

All Versions

Choose a version of io.github.fvarrui : javapackager to add to Maven or Gradle - All Versions:

  • Version Updated
  • javapackager-1.6.7

    Jul 18, 2022
  • javapackager-1.6.6

    Apr 05, 2022
  • javapackager-1.6.5

    Mar 10, 2022
  • javapackager-1.6.4

    Mar 03, 2022
  • javapackager-1.6.3

    Feb 11, 2022
  • javapackager-1.6.2

    Oct 03, 2021
  • javapackager-1.6.1

    Sep 23, 2021
  • javapackager-1.6.0

    Sep 10, 2021
  • javapackager-1.5.1

    Jan 25, 2021
  • javapackager-1.5.0

    Jan 18, 2021
  • javapackager-1.4.2

    Dec 05, 2020
  • javapackager-1.4.1

    Nov 15, 2020
  • javapackager-1.4.0

    Nov 06, 2020
  • javapackager-1.3.0

    Oct 17, 2020
  • javapackager-1.2.0

    Sep 15, 2020
  • javapackager-1.1.0

    Jun 29, 2020
  • javapackager-1.0.3

    Jun 15, 2020
  • javapackager-1.0.2

    Jun 11, 2020
  • javapackager-1.0.1

    Jun 09, 2020
  • javapackager-1.0.0

    Jun 06, 2020
  • javapackager-0.9.7

    Apr 24, 2020
  • javapackager-0.9.6

    Apr 19, 2020
  • javapackager-0.9.5

    Apr 16, 2020
  • javapackager-0.9.4

    Mar 18, 2020
  • javapackager-0.9.3

    Mar 10, 2020
  • javapackager-0.9.2

    Mar 10, 2020
  • javapackager-0.9.1

    Mar 08, 2020
  • javapackager-0.9.0

    Mar 06, 2020

How to add a dependency to Maven

Add the following io.github.fvarrui : javapackager maven dependency to the pom.xml file with your favorite IDE (IntelliJ / Eclipse / Netbeans):

<dependency>
    <groupId>io.github.fvarrui</groupId>
    <artifactId>javapackager</artifactId>
    <version>1.6.7</version>
</dependency>

How to add a dependency to Gradle

Gradle Groovy DSL: Add the following io.github.fvarrui : javapackager gradle dependency to your build.gradle file:

implementation 'io.github.fvarrui:javapackager:1.6.7'

Gradle Kotlin DSL: Add the following io.github.fvarrui : javapackager gradle kotlin dependency to your build.gradle.kts file:

implementation("io.github.fvarrui:javapackager:1.6.7")

How to add a dependency to SBT Scala

SBT Scala: Add the following io.github.fvarrui : javapackager sbt scala dependency to your build.sbt file:

libraryDependencies += "io.github.fvarrui" % "javapackager" % "1.6.7"