MVN

org.gaul : modernizer-maven-plugin

Maven & Gradle

Nov 13, 2022
1 usages

Modernizer Maven Plugin · Detect use of legacy APIs which modern Java versions supersede.

<dependency>
    <groupId>org.gaul</groupId>
    <artifactId>modernizer-maven-plugin</artifactId>
    <version>2.5.0</version>
</dependency>
Copy
pom.xml
Table Of Contents

Latest Version

Choose a version of org.gaul : modernizer-maven-plugin to add to Maven or Gradle - Latest Versions:

  • Latest Stable: 2.5.0

All Versions

Choose a version of org.gaul : modernizer-maven-plugin to add to Maven or Gradle - All Versions:

  • Version Updated
  • modernizer-maven-plugin-2.5.0

    Nov 13, 2022
  • modernizer-maven-plugin-2.4.0

    Mar 06, 2022
  • modernizer-maven-plugin-2.3.0

    Aug 19, 2021
  • modernizer-maven-plugin-2.2.0

    Mar 17, 2021
  • modernizer-maven-plugin-2.1.0

    Mar 22, 2020
  • modernizer-maven-plugin-2.0.0

    Oct 17, 2019
  • modernizer-maven-plugin-1.9.0

    Sep 06, 2019
  • modernizer-maven-plugin-1.8.0

    Feb 03, 2019
  • modernizer-maven-plugin-1.7.1

    Dec 03, 2018
  • modernizer-maven-plugin-1.7.0

    Nov 10, 2018
  • modernizer-maven-plugin-1.6.0

    Jan 17, 2018
  • modernizer-maven-plugin-1.5.0

    Jan 24, 2017
  • modernizer-maven-plugin-1.4.0

    Aug 09, 2015
  • modernizer-maven-plugin-1.3.0

    Mar 09, 2015
  • modernizer-maven-plugin-1.2.2

    Dec 17, 2014
  • modernizer-maven-plugin-1.2.1

    Dec 17, 2014
  • modernizer-maven-plugin-1.2.0

    Dec 17, 2014
  • modernizer-maven-plugin-1.1.0

    Sep 21, 2014
  • modernizer-maven-plugin-1.0.0

    Sep 18, 2014

How to add a dependency to Maven

Add the following org.gaul : modernizer-maven-plugin maven dependency to the pom.xml file with your favorite IDE (IntelliJ / Eclipse / Netbeans):

<dependency>
    <groupId>org.gaul</groupId>
    <artifactId>modernizer-maven-plugin</artifactId>
    <version>2.5.0</version>
</dependency>

How to add a dependency to Gradle

Gradle Groovy DSL: Add the following org.gaul : modernizer-maven-plugin gradle dependency to your build.gradle file:

implementation 'org.gaul:modernizer-maven-plugin:2.5.0'

Gradle Kotlin DSL: Add the following org.gaul : modernizer-maven-plugin gradle kotlin dependency to your build.gradle.kts file:

implementation("org.gaul:modernizer-maven-plugin:2.5.0")

How to add a dependency to SBT Scala

SBT Scala: Add the following org.gaul : modernizer-maven-plugin sbt scala dependency to your build.sbt file:

libraryDependencies += "org.gaul" % "modernizer-maven-plugin" % "2.5.0"