MVN

com.codedx : data-provider-sdk_2.12

Maven & Gradle

Jul 13, 2022
1 usages

data-provider-sdk · SDK for developing ToolReader plugins for Code Dx

<dependency>
    <groupId>com.codedx</groupId>
    <artifactId>data-provider-sdk_2.12</artifactId>
    <version>3.0.0-M2</version>
</dependency>
Copy
pom.xml
Table Of Contents

Latest Version

Choose a version of com.codedx : data-provider-sdk_2.12 to add to Maven or Gradle - Latest Versions:

  • Latest Stable: 3.0.0-M2
  • Latest Release Candidate: 2.0.0-RC5

All Versions

Choose a version of com.codedx : data-provider-sdk_2.12 to add to Maven or Gradle - All Versions:

  • Version Updated
  • data-provider-sdk_2.12-3.0.0-M2

    Jul 13, 2022
  • data-provider-sdk_2.12-3.0.0-M1

    Jul 12, 2022
  • data-provider-sdk_2.12-2.0.0-RC5

    Jan 14, 2022
  • data-provider-sdk_2.12-2.0.0-RC4

    Dec 22, 2021
  • data-provider-sdk_2.12-2.0.0-RC3

    Dec 17, 2021
  • data-provider-sdk_2.12-2.0.0-RC2

    Oct 01, 2021
  • data-provider-sdk_2.12-2.0.0-RC1

    Sep 10, 2021
  • data-provider-sdk_2.12-1.0.1

    Aug 10, 2021
  • data-provider-sdk_2.12-1.0.0

    Jun 07, 2021
  • data-provider-sdk_2.12-0.0.6

    Jun 03, 2021
  • data-provider-sdk_2.12-0.0.5

    Jun 02, 2021
  • data-provider-sdk_2.12-0.0.4

    May 27, 2021
  • data-provider-sdk_2.12-0.0.3

    May 19, 2021
  • data-provider-sdk_2.12-0.0.2

    May 12, 2021
  • data-provider-sdk_2.12-0.0.1

    May 10, 2021

How to add a dependency to Maven

Add the following com.codedx : data-provider-sdk_2.12 maven dependency to the pom.xml file with your favorite IDE (IntelliJ / Eclipse / Netbeans):

<dependency>
    <groupId>com.codedx</groupId>
    <artifactId>data-provider-sdk_2.12</artifactId>
    <version>3.0.0-M2</version>
</dependency>

How to add a dependency to Gradle

Gradle Groovy DSL: Add the following com.codedx : data-provider-sdk_2.12 gradle dependency to your build.gradle file:

implementation 'com.codedx:data-provider-sdk_2.12:3.0.0-M2'

Gradle Kotlin DSL: Add the following com.codedx : data-provider-sdk_2.12 gradle kotlin dependency to your build.gradle.kts file:

implementation("com.codedx:data-provider-sdk_2.12:3.0.0-M2")

How to add a dependency to SBT Scala

SBT Scala: Add the following com.codedx : data-provider-sdk_2.12 sbt scala dependency to your build.sbt file:

libraryDependencies += "com.codedx" % "data-provider-sdk_2.12" % "3.0.0-M2"