MVN

com.github.pires : obd-java-api

Maven & Gradle

Sep 30, 2016
536 stars

OBD Java API · OBD Java API compatible with ELM327.

<dependency>
    <groupId>com.github.pires</groupId>
    <artifactId>obd-java-api</artifactId>
    <version>1.0</version>
</dependency>
Copy
pom.xml
Table Of Contents

Latest Version

Choose a version of com.github.pires : obd-java-api to add to Maven or Gradle - Latest Versions:

  • Latest Stable: 1.0
  • Latest Release Candidate: 1.0-RC16

All Versions

Choose a version of com.github.pires : obd-java-api to add to Maven or Gradle - All Versions:

  • Version Updated
  • obd-java-api-1.0

    Sep 30, 2016
  • obd-java-api-1.0-RC16

    May 12, 2016
  • obd-java-api-1.0-RC15

    Apr 14, 2016
  • obd-java-api-1.0-RC14

    Dec 14, 2015
  • obd-java-api-1.0-RC13

    Dec 11, 2015
  • obd-java-api-1.0-RC12

    Dec 08, 2015
  • obd-java-api-1.0-RC10

    Sep 14, 2015
  • obd-java-api-1.0-RC9

    Aug 31, 2015
  • obd-java-api-1.0-RC8

    Aug 04, 2015
  • obd-java-api-1.0-RC6

    Jul 24, 2015
  • obd-java-api-1.0-RC5

    Jul 21, 2015
  • obd-java-api-1.0-RC4

    Jul 16, 2015
  • obd-java-api-1.0-RC3

    Jul 15, 2015
  • obd-java-api-1.0-RC2

    Jul 10, 2015

How to add a dependency to Maven

Add the following com.github.pires : obd-java-api maven dependency to the pom.xml file with your favorite IDE (IntelliJ / Eclipse / Netbeans):

<dependency>
    <groupId>com.github.pires</groupId>
    <artifactId>obd-java-api</artifactId>
    <version>1.0</version>
</dependency>

How to add a dependency to Gradle

Gradle Groovy DSL: Add the following com.github.pires : obd-java-api gradle dependency to your build.gradle file:

implementation 'com.github.pires:obd-java-api:1.0'

Gradle Kotlin DSL: Add the following com.github.pires : obd-java-api gradle kotlin dependency to your build.gradle.kts file:

implementation("com.github.pires:obd-java-api:1.0")

How to add a dependency to SBT Scala

SBT Scala: Add the following com.github.pires : obd-java-api sbt scala dependency to your build.sbt file:

libraryDependencies += "com.github.pires" % "obd-java-api" % "1.0"