MVN

com.lucidchart : scalafmt-api

Maven & Gradle

Jan 18, 2019
4 usages
155 stars

scalafmt-api · Bridge for scalafmt API

<dependency>
    <groupId>com.lucidchart</groupId>
    <artifactId>scalafmt-api</artifactId>
    <version>1.16</version>
</dependency>
Copy
pom.xml
Table Of Contents

Latest Version

Choose a version of com.lucidchart : scalafmt-api to add to Maven or Gradle - Latest Versions:

  • Latest Stable: 1.16

All Versions

Choose a version of com.lucidchart : scalafmt-api to add to Maven or Gradle - All Versions:

  • Version Updated
  • scalafmt-api-1.16

    Jan 17, 2019
  • scalafmt-api-1.15

    Dec 23, 2017
  • scalafmt-api-1.14

    Oct 24, 2017
  • scalafmt-api-1.13

    Oct 23, 2017
  • scalafmt-api-1.12

    Sep 14, 2017
  • scalafmt-api-1.11

    Sep 07, 2017
  • scalafmt-api-1.10

    Aug 01, 2017
  • scalafmt-api-1.9

    Jul 27, 2017
  • scalafmt-api-1.8

    Jul 10, 2017
  • scalafmt-api-1.7

    Jun 23, 2017
  • scalafmt-api-1.6

    Jun 17, 2017
  • scalafmt-api-1.5

    Jun 17, 2017
  • scalafmt-api-1.4

    Jun 16, 2017
  • scalafmt-api-1.3

    Jun 16, 2017
  • scalafmt-api-1.2

    Jun 16, 2017
  • scalafmt-api-1.1

    Jun 15, 2017
  • scalafmt-api-1.0

    Jun 14, 2017
  • scalafmt-api-0.4

    Jun 06, 2017
  • scalafmt-api-0.3

    May 12, 2017
  • scalafmt-api-0.2

    May 09, 2017
  • scalafmt-api-0.1

    May 09, 2017
  • scalafmt-api-0.0

    May 08, 2017

How to add a dependency to Maven

Add the following com.lucidchart : scalafmt-api maven dependency to the pom.xml file with your favorite IDE (IntelliJ / Eclipse / Netbeans):

<dependency>
    <groupId>com.lucidchart</groupId>
    <artifactId>scalafmt-api</artifactId>
    <version>1.16</version>
</dependency>

How to add a dependency to Gradle

Gradle Groovy DSL: Add the following com.lucidchart : scalafmt-api gradle dependency to your build.gradle file:

implementation 'com.lucidchart:scalafmt-api:1.16'

Gradle Kotlin DSL: Add the following com.lucidchart : scalafmt-api gradle kotlin dependency to your build.gradle.kts file:

implementation("com.lucidchart:scalafmt-api:1.16")

How to add a dependency to SBT Scala

SBT Scala: Add the following com.lucidchart : scalafmt-api sbt scala dependency to your build.sbt file:

libraryDependencies += "com.lucidchart" % "scalafmt-api" % "1.16"