MVN

com.marcnuri.yakc : kubernetes-api

Maven & Gradle

Jul 14, 2023
4 usages
42 stars

Kubernetes API · Retrofit2 based Java interfaces to create a declarative REST API client for Kubernetes.

<dependency>
    <groupId>com.marcnuri.yakc</groupId>
    <artifactId>kubernetes-api</artifactId>
    <version>0.0.27</version>
</dependency>
Copy
pom.xml
Table Of Contents

Latest Version

Choose a version of com.marcnuri.yakc : kubernetes-api to add to Maven or Gradle - Latest Versions:

  • Latest Stable: 0.0.27

All Versions

Choose a version of com.marcnuri.yakc : kubernetes-api to add to Maven or Gradle - All Versions:

Version Vulnerabilities Updated
0.0.x
kubernetes-api-0.0.27
kubernetes-api-0.0.26
kubernetes-api-0.0.25
kubernetes-api-0.0.24
kubernetes-api-0.0.23
kubernetes-api-0.0.22
kubernetes-api-0.0.21
kubernetes-api-0.0.20
kubernetes-api-0.0.19
kubernetes-api-0.0.18
kubernetes-api-0.0.17
kubernetes-api-0.0.16
kubernetes-api-0.0.15
kubernetes-api-0.0.14
kubernetes-api-0.0.13
kubernetes-api-0.0.12
kubernetes-api-0.0.11
kubernetes-api-0.0.10
kubernetes-api-0.0.9
kubernetes-api-0.0.8
kubernetes-api-0.0.7
kubernetes-api-0.0.6
kubernetes-api-0.0.5
kubernetes-api-0.0.4
kubernetes-api-0.0.3
kubernetes-api-0.0.2
kubernetes-api-0.0.1
kubernetes-api-0.0.0

How to add a dependency to Maven

Add the following com.marcnuri.yakc : kubernetes-api maven dependency to the pom.xml file with your favorite IDE (IntelliJ / Eclipse / Netbeans):

<dependency>
    <groupId>com.marcnuri.yakc</groupId>
    <artifactId>kubernetes-api</artifactId>
    <version>0.0.27</version>
</dependency>

How to add a dependency to Gradle

Gradle Groovy DSL: Add the following com.marcnuri.yakc : kubernetes-api gradle dependency to your build.gradle file:

implementation 'com.marcnuri.yakc:kubernetes-api:0.0.27'

Gradle Kotlin DSL: Add the following com.marcnuri.yakc : kubernetes-api gradle kotlin dependency to your build.gradle.kts file:

implementation("com.marcnuri.yakc:kubernetes-api:0.0.27")

How to add a dependency to SBT Scala

SBT Scala: Add the following com.marcnuri.yakc : kubernetes-api sbt scala dependency to your build.sbt file:

libraryDependencies += "com.marcnuri.yakc" % "kubernetes-api" % "0.0.27"

Advertisement