MVN

com.sksamuel.scapegoat : scalac-scapegoat-plugin_2.13.7

Maven & Gradle

Sep 29, 2022
1 usages
493 stars

scalac-scapegoat-plugin · Scala compiler plugin for static code analysis

<dependency>
    <groupId>com.sksamuel.scapegoat</groupId>
    <artifactId>scalac-scapegoat-plugin_2.13.7</artifactId>
    <version>1.4.16</version>
</dependency>
Copy
pom.xml
Table Of Contents

Latest Version

Choose a version of com.sksamuel.scapegoat : scalac-scapegoat-plugin_2.13.7 to add to Maven or Gradle - Latest Versions:

  • Latest Stable: 1.4.16

All Versions

Choose a version of com.sksamuel.scapegoat : scalac-scapegoat-plugin_2.13.7 to add to Maven or Gradle - All Versions:

Version Vulnerabilities Updated
1.4.x
scalac-scapegoat-plugin_2.13.7-1.4.16
scalac-scapegoat-plugin_2.13.7-1.4.15
scalac-scapegoat-plugin_2.13.7-1.4.14
scalac-scapegoat-plugin_2.13.7-1.4.13
scalac-scapegoat-plugin_2.13.7-1.4.12
scalac-scapegoat-plugin_2.13.7-1.4.11

How to add a dependency to Maven

Add the following com.sksamuel.scapegoat : scalac-scapegoat-plugin_2.13.7 maven dependency to the pom.xml file with your favorite IDE (IntelliJ / Eclipse / Netbeans):

<dependency>
    <groupId>com.sksamuel.scapegoat</groupId>
    <artifactId>scalac-scapegoat-plugin_2.13.7</artifactId>
    <version>1.4.16</version>
</dependency>

How to add a dependency to Gradle

Gradle Groovy DSL: Add the following com.sksamuel.scapegoat : scalac-scapegoat-plugin_2.13.7 gradle dependency to your build.gradle file:

implementation 'com.sksamuel.scapegoat:scalac-scapegoat-plugin_2.13.7:1.4.16'

Gradle Kotlin DSL: Add the following com.sksamuel.scapegoat : scalac-scapegoat-plugin_2.13.7 gradle kotlin dependency to your build.gradle.kts file:

implementation("com.sksamuel.scapegoat:scalac-scapegoat-plugin_2.13.7:1.4.16")

How to add a dependency to SBT Scala

SBT Scala: Add the following com.sksamuel.scapegoat : scalac-scapegoat-plugin_2.13.7 sbt scala dependency to your build.sbt file:

libraryDependencies += "com.sksamuel.scapegoat" % "scalac-scapegoat-plugin_2.13.7" % "1.4.16"

Advertisement