MVN

com.webcohesion.enunciate : enunciate-lombok

Maven & Gradle

Mar 22, 2022
463 stars

Enunciate - Project Lombok Support · Support for project Lombok.

<dependency>
    <groupId>com.webcohesion.enunciate</groupId>
    <artifactId>enunciate-lombok</artifactId>
    <version>2.14.0</version>
</dependency>
Copy
pom.xml
Table Of Contents

Latest Version

Choose a version of com.webcohesion.enunciate : enunciate-lombok to add to Maven or Gradle - Latest Versions:

  • Latest Stable: 2.14.0

All Versions

Choose a version of com.webcohesion.enunciate : enunciate-lombok to add to Maven or Gradle - All Versions:

  • Version Updated
  • enunciate-lombok-2.14.0

    Mar 21, 2022
  • enunciate-lombok-2.13.3

    Mar 09, 2021
  • enunciate-lombok-2.13.2

    Aug 28, 2020
  • enunciate-lombok-2.13.1

    May 22, 2020
  • enunciate-lombok-2.13.0

    Apr 29, 2020
  • enunciate-lombok-2.12.1

    Oct 14, 2019
  • enunciate-lombok-2.12.0

    Aug 10, 2019
  • enunciate-lombok-2.11.1

    May 16, 2018
  • enunciate-lombok-2.11.0

    May 07, 2018
  • enunciate-lombok-2.10.1

    Oct 30, 2017
  • enunciate-lombok-2.10.0

    Oct 26, 2017
  • enunciate-lombok-2.9.1

    Apr 10, 2017
  • enunciate-lombok-2.9.0

    Apr 07, 2017
  • enunciate-lombok-2.8.1

    Feb 17, 2017
  • enunciate-lombok-2.8.0

    Dec 19, 2016
  • enunciate-lombok-2.7.0

    Oct 28, 2016

How to add a dependency to Maven

Add the following com.webcohesion.enunciate : enunciate-lombok maven dependency to the pom.xml file with your favorite IDE (IntelliJ / Eclipse / Netbeans):

<dependency>
    <groupId>com.webcohesion.enunciate</groupId>
    <artifactId>enunciate-lombok</artifactId>
    <version>2.14.0</version>
</dependency>

How to add a dependency to Gradle

Gradle Groovy DSL: Add the following com.webcohesion.enunciate : enunciate-lombok gradle dependency to your build.gradle file:

implementation 'com.webcohesion.enunciate:enunciate-lombok:2.14.0'

Gradle Kotlin DSL: Add the following com.webcohesion.enunciate : enunciate-lombok gradle kotlin dependency to your build.gradle.kts file:

implementation("com.webcohesion.enunciate:enunciate-lombok:2.14.0")

How to add a dependency to SBT Scala

SBT Scala: Add the following com.webcohesion.enunciate : enunciate-lombok sbt scala dependency to your build.sbt file:

libraryDependencies += "com.webcohesion.enunciate" % "enunciate-lombok" % "2.14.0"