MVN

com.yahoo.pulsar : pulsar-client

Maven & Gradle

Jun 17, 2017
2 usages
10k stars

Pulsar Client Java

<dependency>
    <groupId>com.yahoo.pulsar</groupId>
    <artifactId>pulsar-client</artifactId>
    <version>1.18</version>
</dependency>
Copy
pom.xml
Table Of Contents

Latest Version

Choose a version of com.yahoo.pulsar : pulsar-client to add to Maven or Gradle - Latest Versions:

  • Latest Stable: 1.18

All Versions

Choose a version of com.yahoo.pulsar : pulsar-client to add to Maven or Gradle - All Versions:

  • Version Updated
  • pulsar-client-1.18

    Jun 17, 2017
  • pulsar-client-1.17.5

    May 03, 2017
  • pulsar-client-1.17.4

    Apr 25, 2017
  • pulsar-client-1.17.3

    Apr 20, 2017
  • pulsar-client-1.17.2

    Apr 07, 2017
  • pulsar-client-1.17.1

    Mar 31, 2017
  • pulsar-client-1.17

    Mar 31, 2017
  • pulsar-client-1.16.5

    Mar 24, 2017
  • pulsar-client-1.16.4

    Mar 10, 2017
  • pulsar-client-1.16.3

    Mar 04, 2017
  • pulsar-client-1.16.2

    Feb 28, 2017
  • pulsar-client-1.16.1

    Feb 25, 2017
  • pulsar-client-1.16

    Feb 02, 2017
  • pulsar-client-1.15.7

    Jan 26, 2017
  • pulsar-client-1.15.6

    Jan 20, 2017
  • pulsar-client-1.15.5

    Jan 04, 2017
  • pulsar-client-1.15.4

    Dec 15, 2016
  • pulsar-client-1.15.3

    Dec 14, 2016
  • pulsar-client-1.15.2

    Nov 03, 2016
  • pulsar-client-1.15.1

    Oct 27, 2016
  • pulsar-client-1.15

    Oct 18, 2016
  • pulsar-client-1.14

    Sep 10, 2016

How to add a dependency to Maven

Add the following com.yahoo.pulsar : pulsar-client maven dependency to the pom.xml file with your favorite IDE (IntelliJ / Eclipse / Netbeans):

<dependency>
    <groupId>com.yahoo.pulsar</groupId>
    <artifactId>pulsar-client</artifactId>
    <version>1.18</version>
</dependency>

How to add a dependency to Gradle

Gradle Groovy DSL: Add the following com.yahoo.pulsar : pulsar-client gradle dependency to your build.gradle file:

implementation 'com.yahoo.pulsar:pulsar-client:1.18'

Gradle Kotlin DSL: Add the following com.yahoo.pulsar : pulsar-client gradle kotlin dependency to your build.gradle.kts file:

implementation("com.yahoo.pulsar:pulsar-client:1.18")

How to add a dependency to SBT Scala

SBT Scala: Add the following com.yahoo.pulsar : pulsar-client sbt scala dependency to your build.sbt file:

libraryDependencies += "com.yahoo.pulsar" % "pulsar-client" % "1.18"