MVN

de.adrodoc55.mpl : mpl-ide

Maven & Gradle

Sep 19, 2017
17 stars

Minecraft Programming Language (MPL) · MPL is a language that makes it easier to write applications for Minecraft 1.9 or higher. The final result of compiling an MPL application are command blocks that can be imported into your world in various ways. MPL comes with it's own editor that supports syntax- and error-highlighting and has a built in compiler.

<dependency>
    <groupId>de.adrodoc55.mpl</groupId>
    <artifactId>mpl-ide</artifactId>
    <version>1.3.2</version>
</dependency>
Copy
pom.xml
Table Of Contents

Latest Version

Choose a version of de.adrodoc55.mpl : mpl-ide to add to Maven or Gradle - Latest Versions:

  • Latest Stable: 1.3.2

All Versions

Choose a version of de.adrodoc55.mpl : mpl-ide to add to Maven or Gradle - All Versions:

  • Version Updated
  • mpl-ide-1.3.2

    Sep 18, 2017
  • mpl-ide-1.3.1

    Jul 06, 2017
  • mpl-ide-1.3.0

    Jun 12, 2017
  • mpl-ide-1.2.1

    Feb 12, 2017
  • mpl-ide-1.2.0

    Oct 23, 2016
  • mpl-ide-1.1.0

    Oct 03, 2016
  • mpl-ide-1.0.1

    Jul 03, 2016
  • mpl-ide-1.0.0

    Jun 29, 2016
  • mpl-ide-0.11.0

    Jun 04, 2016
  • mpl-ide-0.10.1

    Jun 04, 2016
  • mpl-ide-0.10.0

    May 25, 2016

How to add a dependency to Maven

Add the following de.adrodoc55.mpl : mpl-ide maven dependency to the pom.xml file with your favorite IDE (IntelliJ / Eclipse / Netbeans):

<dependency>
    <groupId>de.adrodoc55.mpl</groupId>
    <artifactId>mpl-ide</artifactId>
    <version>1.3.2</version>
</dependency>

How to add a dependency to Gradle

Gradle Groovy DSL: Add the following de.adrodoc55.mpl : mpl-ide gradle dependency to your build.gradle file:

implementation 'de.adrodoc55.mpl:mpl-ide:1.3.2'

Gradle Kotlin DSL: Add the following de.adrodoc55.mpl : mpl-ide gradle kotlin dependency to your build.gradle.kts file:

implementation("de.adrodoc55.mpl:mpl-ide:1.3.2")

How to add a dependency to SBT Scala

SBT Scala: Add the following de.adrodoc55.mpl : mpl-ide sbt scala dependency to your build.sbt file:

libraryDependencies += "de.adrodoc55.mpl" % "mpl-ide" % "1.3.2"