MVN

io.sentry : sentry

Maven & Gradle

Aug 04, 2023
68 usages
1k stars

Sentry SDK · SDK for sentry.io

<dependency>
    <groupId>io.sentry</groupId>
    <artifactId>sentry</artifactId>
    <version>6.28.0</version>
</dependency>
Copy
pom.xml
Table Of Contents

Latest Version

Choose a version of io.sentry : sentry to add to Maven or Gradle - Latest Versions:

  • Latest Stable: 6.28.0
  • Latest Release Candidate: 6.0.0-rc.1
  • Latest Beta: 6.16.0-beta.1
  • Latest Alpha: 6.7.0-alpha.1

All Versions

Choose a version of io.sentry : sentry to add to Maven or Gradle - All Versions:

Version Vulnerabilities Updated
6.28.x
sentry-6.28.0
6.27.x
sentry-6.27.0
6.26.x
sentry-6.26.0
6.25.x
sentry-6.25.2
sentry-6.25.1
sentry-6.25.0
6.24.x
sentry-6.24.0
6.23.x
sentry-6.23.0
6.22.x
sentry-6.22.0
6.21.x
sentry-6.21.0
6.20.x
sentry-6.20.0
6.19.x
sentry-6.19.1
sentry-6.19.0
6.18.x
sentry-6.18.1
sentry-6.18.0
6.17.x
sentry-6.17.0
6.16.x
sentry-6.16.0
sentry-6.16.0-beta.1
6.15.x
sentry-6.15.0
6.14.x
sentry-6.14.0
6.13.x
sentry-6.13.1
sentry-6.13.0
6.12.x
sentry-6.12.1
sentry-6.12.0
6.11.x
sentry-6.11.0
6.10.x
sentry-6.10.0
6.9.x
sentry-6.9.2
sentry-6.9.1
sentry-6.9.0
6.8.x
sentry-6.8.0
6.7.x
sentry-6.7.1
sentry-6.7.0
sentry-6.7.0-alpha.1
6.6.x
sentry-6.6.0
6.5.x
sentry-6.5.0
sentry-6.5.0-beta.3
sentry-6.5.0-beta.2
sentry-6.5.0-beta.1
6.4.x
sentry-6.4.4
sentry-6.4.3
sentry-6.4.2
sentry-6.4.1
sentry-6.4.0
6.3.x
sentry-6.3.1
sentry-6.3.0
6.2.x
sentry-6.2.1
sentry-6.2.0
6.1.x
sentry-6.1.4
sentry-6.1.3
sentry-6.1.2
sentry-6.1.1
sentry-6.1.0
6.0.x
sentry-6.0.0
sentry-6.0.0-rc.1
sentry-6.0.0-beta.4
sentry-6.0.0-beta.3
sentry-6.0.0-beta.2
sentry-6.0.0-beta.1
sentry-6.0.0-alpha.6
sentry-6.0.0-alpha.5
sentry-6.0.0-alpha.4
sentry-6.0.0-alpha.3
sentry-6.0.0-alpha.2
sentry-6.0.0-alpha.1
5.7.x
sentry-5.7.4
sentry-5.7.3
sentry-5.7.2
sentry-5.7.1
sentry-5.7.0
5.6.x
sentry-5.6.3
sentry-5.6.2
sentry-5.6.2-beta.3
sentry-5.6.2-beta.2
sentry-5.6.2-beta.1
sentry-5.6.1
sentry-5.6.0
5.5.x
sentry-5.5.3
sentry-5.5.2
sentry-5.5.1
sentry-5.5.0
5.4.x
sentry-5.4.3
sentry-5.4.2
sentry-5.4.1
sentry-5.4.0
5.3.x
sentry-5.3.0
5.2.x
sentry-5.2.4
sentry-5.2.3
sentry-5.2.2
sentry-5.2.1
sentry-5.2.0
sentry-5.2.0-beta.3
sentry-5.2.0-beta.2
sentry-5.2.0-beta.1
5.1.x
sentry-5.1.2
sentry-5.1.1
sentry-5.1.0
sentry-5.1.0-beta.9
sentry-5.1.0-beta.8
sentry-5.1.0-beta.7
sentry-5.1.0-beta.6
sentry-5.1.0-beta.5
sentry-5.1.0-beta.4
sentry-5.1.0-beta.3
sentry-5.1.0-beta.2
sentry-5.1.0-beta.1
5.0.x
sentry-5.0.1
sentry-5.0.0
sentry-5.0.0-beta.7
sentry-5.0.0-beta.6
sentry-5.0.0-beta.5
sentry-5.0.0-beta.4
sentry-5.0.0-beta.3
sentry-5.0.0-beta.2
sentry-5.0.0-beta.1
4.4.x
sentry-4.4.0-alpha.2
sentry-4.4.0-alpha.1
4.3.x
sentry-4.3.0
4.2.x
sentry-4.2.0
4.1.x
sentry-4.1.0
4.0.x
sentry-4.0.0
sentry-4.0.0-beta.1
sentry-4.0.0-alpha.3
sentry-4.0.0-alpha.2
sentry-4.0.0-alpha.1
3.2.x
sentry-3.2.1
sentry-3.2.0
3.1.x
sentry-3.1.3
sentry-3.1.2
sentry-3.1.1
sentry-3.1.0
3.0.x
sentry-3.0.0
sentry-3.0.0-beta.1
1.7.x
sentry-1.7.30
sentry-1.7.29
sentry-1.7.28
sentry-1.7.27
sentry-1.7.26
sentry-1.7.25
sentry-1.7.24
sentry-1.7.23
sentry-1.7.22
sentry-1.7.21
sentry-1.7.20
sentry-1.7.19
sentry-1.7.18
sentry-1.7.17
sentry-1.7.16
sentry-1.7.15
sentry-1.7.14
sentry-1.7.13
sentry-1.7.12
sentry-1.7.11
sentry-1.7.10
sentry-1.7.9
sentry-1.7.8
sentry-1.7.7
sentry-1.7.6
sentry-1.7.5
sentry-1.7.4
sentry-1.7.3
sentry-1.7.2
sentry-1.7.1
sentry-1.7.0
1.6.x
sentry-1.6.8
sentry-1.6.7
sentry-1.6.6
sentry-1.6.5
sentry-1.6.4
sentry-1.6.3
sentry-1.6.2
sentry-1.6.1
sentry-1.6.0
1.5.x
sentry-1.5.6
sentry-1.5.5
sentry-1.5.4
sentry-1.5.3
sentry-1.5.2
sentry-1.5.1
sentry-1.5.0
1.4.x
sentry-1.4.0
1.3.x
sentry-1.3.1
sentry-1.3.0
1.2.x
sentry-1.2.2
sentry-1.2.1
sentry-1.2.0
1.1.x
sentry-1.1.0
1.0.x
sentry-1.0.0
sentry-1.0.0-beta3
sentry-1.0.0-beta2
sentry-1.0.0-beta

How to add a dependency to Maven

Add the following io.sentry : sentry maven dependency to the pom.xml file with your favorite IDE (IntelliJ / Eclipse / Netbeans):

<dependency>
    <groupId>io.sentry</groupId>
    <artifactId>sentry</artifactId>
    <version>6.28.0</version>
</dependency>

How to add a dependency to Gradle

Gradle Groovy DSL: Add the following io.sentry : sentry gradle dependency to your build.gradle file:

implementation 'io.sentry:sentry:6.28.0'

Gradle Kotlin DSL: Add the following io.sentry : sentry gradle kotlin dependency to your build.gradle.kts file:

implementation("io.sentry:sentry:6.28.0")

How to add a dependency to SBT Scala

SBT Scala: Add the following io.sentry : sentry sbt scala dependency to your build.sbt file:

libraryDependencies += "io.sentry" % "sentry" % "6.28.0"

Advertisement

Dependencies from Group

Aug 04, 2023
68 usages
1k stars
Aug 04, 2023
27 usages
1k stars
Aug 04, 2023
23 usages
1k stars
Aug 04, 2023
9 usages
1k stars
Aug 04, 2023
9 usages
1k stars

Discover Dependencies

Jul 19, 2023
32 stars
Sep 14, 2021
181 usages
Aug 07, 2023
39 stars
May 20, 2017
16 stars
Aug 08, 2017
2 usages
49 stars
May 09, 2021
32 usages
283 stars
Dec 17, 2018
1 usages
0 stars
Apr 07, 2021
111 usages
1.9k stars
Jan 02, 2020
14 usages
Apr 18, 2018
2 usages
5 stars