MVN

no.nordicsemi.android : ble

Maven & Gradle

Jun 07, 2022
6 usages
1k stars

Bluetooth Low Energy library for Android · Bluetooth Low Energy library for Android

<dependency>
    <groupId>no.nordicsemi.android</groupId>
    <artifactId>ble</artifactId>
    <version>2.5.1</version>
</dependency>
Copy
pom.xml
Table Of Contents

Latest Version

Choose a version of no.nordicsemi.android : ble to add to Maven or Gradle - Latest Versions:

  • Latest Stable: 2.5.1
  • Latest Beta: 2.4.0-beta03
  • Latest Alpha: 2.2.0-alpha13

All Versions

Choose a version of no.nordicsemi.android : ble to add to Maven or Gradle - All Versions:

  • Version Updated
  • ble-2.5.1

    Jun 07, 2022
  • ble-2.5.0

    Jun 03, 2022
  • ble-2.4.1

    May 10, 2022
  • ble-2.4.0

    Mar 22, 2022
  • ble-2.4.0-beta03

    Mar 18, 2022
  • ble-2.4.0.beta02

    Feb 16, 2022
  • ble-2.4.0-beta01

    Feb 02, 2022
  • ble-2.3.1

    Sep 23, 2021
  • ble-2.3.0

    Jun 23, 2021
  • ble-2.2.4

    Aug 12, 2020
  • ble-2.2.3

    Jul 06, 2020
  • ble-2.2.2

    Jul 03, 2020
  • ble-2.2.1

    Jun 30, 2020
  • ble-2.2.0

    May 14, 2020
  • ble-2.2.0-beta03

    May 12, 2020
  • ble-2.2.0-beta02

    May 07, 2020
  • ble-2.2.0-beta01

    Apr 03, 2020
  • ble-2.2.0-alpha13

    Apr 03, 2020
  • ble-2.2.0-alpha12

    Apr 03, 2020
  • ble-2.2.0-alpha11

    Apr 02, 2020
  • ble-2.2.0-alpha10

    Apr 02, 2020
  • ble-2.2.0-alpha09

    Apr 02, 2020
  • ble-2.2.0-alpha08

    Apr 02, 2020
  • ble-2.2.0-alpha07

    Mar 31, 2020
  • ble-2.2.0-alpha06

    Jan 31, 2020
  • ble-2.2.0-alpha04

    Jan 27, 2020
  • ble-2.2.0-alpha03

    Jan 13, 2020
  • ble-2.2.0-alpha02

    Jan 02, 2020
  • ble-2.2.0-alpha01

    Jan 02, 2020
  • ble-2.1.1

    Mar 14, 2019
  • ble-2.1.0

    Feb 01, 2019
  • ble-2.0.5

    Feb 01, 2019
  • ble-2.0.0

    Nov 08, 2018

How to add a dependency to Maven

Add the following no.nordicsemi.android : ble maven dependency to the pom.xml file with your favorite IDE (IntelliJ / Eclipse / Netbeans):

<dependency>
    <groupId>no.nordicsemi.android</groupId>
    <artifactId>ble</artifactId>
    <version>2.5.1</version>
</dependency>

How to add a dependency to Gradle

Gradle Groovy DSL: Add the following no.nordicsemi.android : ble gradle dependency to your build.gradle file:

implementation 'no.nordicsemi.android:ble:2.5.1'

Gradle Kotlin DSL: Add the following no.nordicsemi.android : ble gradle kotlin dependency to your build.gradle.kts file:

implementation("no.nordicsemi.android:ble:2.5.1")

How to add a dependency to SBT Scala

SBT Scala: Add the following no.nordicsemi.android : ble sbt scala dependency to your build.sbt file:

libraryDependencies += "no.nordicsemi.android" % "ble" % "2.5.1"