MVN

org.aarboard.nextcloud : nextcloud-api

Maven & Gradle

Apr 01, 2022
1 usages
55 stars

NextCloud Java API library · Java api library to access nextcloud features from java applications

<dependency>
    <groupId>org.aarboard.nextcloud</groupId>
    <artifactId>nextcloud-api</artifactId>
    <version>12.0.2</version>
</dependency>
Copy
pom.xml
Table Of Contents

Latest Version

Choose a version of org.aarboard.nextcloud : nextcloud-api to add to Maven or Gradle - Latest Versions:

  • Latest Stable: 12.0.2

All Versions

Choose a version of org.aarboard.nextcloud : nextcloud-api to add to Maven or Gradle - All Versions:

  • Version Updated
  • nextcloud-api-12.0.2

    Apr 01, 2022
  • nextcloud-api-12.0.1

    Apr 01, 2022
  • nextcloud-api-12.0.0

    Nov 02, 2021
  • nextcloud-api-11.6.0

    Oct 04, 2021
  • nextcloud-api-11.5.1

    Sep 09, 2021
  • nextcloud-api-11.5.0

    May 20, 2021
  • nextcloud-api-11.4.1

    Apr 27, 2021
  • nextcloud-api-11.4.0

    Nov 21, 2020
  • nextcloud-api-11.3.0

    Jul 15, 2020
  • nextcloud-api-11.2.0

    May 07, 2020
  • nextcloud-api-11.1.0

    Feb 24, 2020
  • nextcloud-api-11.0.3

    Dec 03, 2018
  • nextcloud-api-11.0.2

    Aug 03, 2018
  • nextcloud-api-11.0.1

    Jul 25, 2018

How to add a dependency to Maven

Add the following org.aarboard.nextcloud : nextcloud-api maven dependency to the pom.xml file with your favorite IDE (IntelliJ / Eclipse / Netbeans):

<dependency>
    <groupId>org.aarboard.nextcloud</groupId>
    <artifactId>nextcloud-api</artifactId>
    <version>12.0.2</version>
</dependency>

How to add a dependency to Gradle

Gradle Groovy DSL: Add the following org.aarboard.nextcloud : nextcloud-api gradle dependency to your build.gradle file:

implementation 'org.aarboard.nextcloud:nextcloud-api:12.0.2'

Gradle Kotlin DSL: Add the following org.aarboard.nextcloud : nextcloud-api gradle kotlin dependency to your build.gradle.kts file:

implementation("org.aarboard.nextcloud:nextcloud-api:12.0.2")

How to add a dependency to SBT Scala

SBT Scala: Add the following org.aarboard.nextcloud : nextcloud-api sbt scala dependency to your build.sbt file:

libraryDependencies += "org.aarboard.nextcloud" % "nextcloud-api" % "12.0.2"