MVN

org.apache.camel : camel-script

Maven & Gradle

May 24, 2021
45 usages

Camel :: Script (deprecated) · Camel Script support

<dependency>
    <groupId>org.apache.camel</groupId>
    <artifactId>camel-script</artifactId>
    <version>2.25.4</version>
</dependency>
Copy
pom.xml
Table Of Contents

Latest Version

Choose a version of org.apache.camel : camel-script to add to Maven or Gradle - Latest Versions:

  • Latest Stable: 2.25.4
  • Latest Release Candidate: 2.9.0-RC1

All Versions

Choose a version of org.apache.camel : camel-script to add to Maven or Gradle - All Versions:

Version Vulnerabilities Updated
3.0.x
camel-script-3.0.0-M2
camel-script-3.0.0-M1
2.25.x
camel-script-2.25.4
camel-script-2.25.3
camel-script-2.25.2
camel-script-2.25.1
camel-script-2.25.0
2.24.x
camel-script-2.24.3
camel-script-2.24.2
camel-script-2.24.1
camel-script-2.24.0
2.23.x
camel-script-2.23.4
camel-script-2.23.3
camel-script-2.23.2
camel-script-2.23.1
camel-script-2.23.0
2.22.x
camel-script-2.22.5
camel-script-2.22.4
camel-script-2.22.3
camel-script-2.22.2
camel-script-2.22.1
camel-script-2.22.0
2.21.x
camel-script-2.21.5
camel-script-2.21.4
camel-script-2.21.3
camel-script-2.21.2
camel-script-2.21.1
camel-script-2.21.0
2.20.x
camel-script-2.20.4
camel-script-2.20.3
camel-script-2.20.2
camel-script-2.20.1
camel-script-2.20.0
2.19.x
camel-script-2.19.5
camel-script-2.19.4
camel-script-2.19.3
camel-script-2.19.2
camel-script-2.19.1
camel-script-2.19.0
2.18.x
camel-script-2.18.5
camel-script-2.18.4
camel-script-2.18.3
camel-script-2.18.2
camel-script-2.18.1
camel-script-2.18.0
2.17.x
camel-script-2.17.7
camel-script-2.17.6
camel-script-2.17.5
camel-script-2.17.4
camel-script-2.17.3
camel-script-2.17.2
camel-script-2.17.1
camel-script-2.17.0
2.16.x
camel-script-2.16.5
camel-script-2.16.4
camel-script-2.16.3
camel-script-2.16.2
camel-script-2.16.1
camel-script-2.16.0
2.15.x
camel-script-2.15.6
camel-script-2.15.5
camel-script-2.15.4
camel-script-2.15.3
camel-script-2.15.2
camel-script-2.15.1
camel-script-2.15.0
2.14.x
camel-script-2.14.4
camel-script-2.14.3
camel-script-2.14.2
camel-script-2.14.1
camel-script-2.14.0
2.13.x
camel-script-2.13.4
camel-script-2.13.3
camel-script-2.13.2
camel-script-2.13.1
camel-script-2.13.0
2.12.x
camel-script-2.12.5
camel-script-2.12.4
camel-script-2.12.3
camel-script-2.12.2
camel-script-2.12.1
camel-script-2.12.0
2.11.x
camel-script-2.11.4
camel-script-2.11.3
camel-script-2.11.2
camel-script-2.11.1
camel-script-2.11.0
2.10.x
camel-script-2.10.7
camel-script-2.10.6
camel-script-2.10.5
camel-script-2.10.4
camel-script-2.10.3
camel-script-2.10.2
camel-script-2.10.1
camel-script-2.10.0
2.9.x
camel-script-2.9.8
camel-script-2.9.7
camel-script-2.9.6
camel-script-2.9.5
camel-script-2.9.4
camel-script-2.9.3
camel-script-2.9.2
camel-script-2.9.1
camel-script-2.9.0
camel-script-2.9.0-RC1
2.8.x
camel-script-2.8.6
camel-script-2.8.5
camel-script-2.8.4
camel-script-2.8.3
camel-script-2.8.2
camel-script-2.8.1
camel-script-2.8.0
2.7.x
camel-script-2.7.5
camel-script-2.7.4
camel-script-2.7.3
camel-script-2.7.2
camel-script-2.7.1
camel-script-2.7.0
2.6.x
camel-script-2.6.0
2.5.x
camel-script-2.5.0
2.4.x
camel-script-2.4.0
2.3.x
camel-script-2.3.0
2.2.x
camel-script-2.2.0
2.1.x
camel-script-2.1.0
2.0.x
camel-script-2.0.0
2.0
camel-script-2.0-M3
camel-script-2.0-M2
camel-script-2.0-M1
1.6.x
camel-script-1.6.4
camel-script-1.6.3
camel-script-1.6.2
camel-script-1.6.1
camel-script-1.6.0
1.5.x
camel-script-1.5.0
1.4.x
camel-script-1.4.0
1.3.x
camel-script-1.3.0
1.2.x
camel-script-1.2.0
1.1.x
camel-script-1.1.0
1.0.x
camel-script-1.0.0

How to add a dependency to Maven

Add the following org.apache.camel : camel-script maven dependency to the pom.xml file with your favorite IDE (IntelliJ / Eclipse / Netbeans):

<dependency>
    <groupId>org.apache.camel</groupId>
    <artifactId>camel-script</artifactId>
    <version>2.25.4</version>
</dependency>

How to add a dependency to Gradle

Gradle Groovy DSL: Add the following org.apache.camel : camel-script gradle dependency to your build.gradle file:

implementation 'org.apache.camel:camel-script:2.25.4'

Gradle Kotlin DSL: Add the following org.apache.camel : camel-script gradle kotlin dependency to your build.gradle.kts file:

implementation("org.apache.camel:camel-script:2.25.4")

How to add a dependency to SBT Scala

SBT Scala: Add the following org.apache.camel : camel-script sbt scala dependency to your build.sbt file:

libraryDependencies += "org.apache.camel" % "camel-script" % "2.25.4"

Advertisement

Dependencies from Group

Aug 10, 2023
1.4k usages
27 stars
Aug 10, 2023
663 usages
27 stars
Jun 23, 2023
657 usages
27 stars
May 24, 2021
624 usages

Discover Dependencies

May 24, 2021
43 usages
Aug 10, 2023
54 usages
27 stars
Aug 10, 2023
58 usages
27 stars
Aug 10, 2023
29 usages
27 stars
Jun 13, 2023
219 usages
27 stars
Jun 23, 2023
115 usages
27 stars
May 24, 2021
149 usages
Jun 13, 2023
29 usages
26 stars
Jul 12, 2023
129 usages
9.2k stars
Aug 23, 2023
53 usages
31.4k stars