MVN

org.apache.samza : samza-api

Maven & Gradle

Jan 13, 2023
71 usages

Apache Samza · A distributed stream processing framework built upon Apache Kafka and Apache Hadoop YARN.

<dependency>
    <groupId>org.apache.samza</groupId>
    <artifactId>samza-api</artifactId>
    <version>1.8.0</version>
</dependency>
Copy
pom.xml
Table Of Contents

Latest Version

Choose a version of org.apache.samza : samza-api to add to Maven or Gradle - Latest Versions:

  • Latest Stable: 1.8.0

All Versions

Choose a version of org.apache.samza : samza-api to add to Maven or Gradle - All Versions:

  • Version Updated
  • samza-api-1.8.0

    Jan 13, 2023
  • samza-api-1.7.0

    Mar 09, 2022
  • samza-api-1.6.0

    Jan 07, 2021
  • samza-api-1.5.1

    Aug 19, 2020
  • samza-api-1.5.0

    Jun 09, 2020
  • samza-api-1.4.0

    Mar 11, 2020
  • samza-api-1.3.1

    Feb 13, 2020
  • samza-api-1.3.0

    Nov 27, 2019
  • samza-api-1.2.0

    Jun 06, 2019
  • samza-api-1.1.0

    Mar 09, 2019
  • samza-api-1.0.0

    Nov 01, 2018
  • samza-api-0.14.1

    May 18, 2018
  • samza-api-0.14.0

    Dec 21, 2017
  • samza-api-0.13.1

    Aug 24, 2017
  • samza-api-0.13.0

    Jun 05, 2017
  • samza-api-0.12.0

    Feb 06, 2017
  • samza-api-0.11.0

    Oct 10, 2016
  • samza-api-0.10.1

    Jul 30, 2016
  • samza-api-0.10.0

    Dec 08, 2015
  • samza-api-0.9.1

    Jun 28, 2015
  • samza-api-0.9.0

    Mar 24, 2015
  • samza-api-0.8.0

    Nov 25, 2014
  • samza-api-0.7.0

    Jun 27, 2014

How to add a dependency to Maven

Add the following org.apache.samza : samza-api maven dependency to the pom.xml file with your favorite IDE (IntelliJ / Eclipse / Netbeans):

<dependency>
    <groupId>org.apache.samza</groupId>
    <artifactId>samza-api</artifactId>
    <version>1.8.0</version>
</dependency>

How to add a dependency to Gradle

Gradle Groovy DSL: Add the following org.apache.samza : samza-api gradle dependency to your build.gradle file:

implementation 'org.apache.samza:samza-api:1.8.0'

Gradle Kotlin DSL: Add the following org.apache.samza : samza-api gradle kotlin dependency to your build.gradle.kts file:

implementation("org.apache.samza:samza-api:1.8.0")

How to add a dependency to SBT Scala

SBT Scala: Add the following org.apache.samza : samza-api sbt scala dependency to your build.sbt file:

libraryDependencies += "org.apache.samza" % "samza-api" % "1.8.0"