MVN

org.apache.sling : org.apache.sling.jcr.api

Maven & Gradle

Jun 21, 2016
285 usages

Apache Sling Repository API Bundle · This OSGi bundle provides the JCR packages as well as a helper service interface to be implemented and provided by repository providers.

<dependency>
    <groupId>org.apache.sling</groupId>
    <artifactId>org.apache.sling.jcr.api</artifactId>
    <version>2.4.0</version>
</dependency>
Copy
pom.xml
Table Of Contents

Latest Version

Choose a version of org.apache.sling : org.apache.sling.jcr.api to add to Maven or Gradle - Latest Versions:

  • Latest Stable: 2.4.0

All Versions

Choose a version of org.apache.sling : org.apache.sling.jcr.api to add to Maven or Gradle - All Versions:

  • Version Updated
  • org.apache.sling.jcr.api-2.4.0

    Jun 21, 2016
  • org.apache.sling.jcr.api-2.3.0

    Aug 11, 2015
  • org.apache.sling.jcr.api-2.2.0

    Jan 30, 2014
  • org.apache.sling.jcr.api-2.1.0

    Sep 06, 2010
  • org.apache.sling.jcr.api-2.0.6

    Jan 26, 2010
  • org.apache.sling.jcr.api-2.0.4

    Aug 12, 2009
  • org.apache.sling.jcr.api-2.0.2-incubator

    Jun 13, 2009

How to add a dependency to Maven

Add the following org.apache.sling : org.apache.sling.jcr.api maven dependency to the pom.xml file with your favorite IDE (IntelliJ / Eclipse / Netbeans):

<dependency>
    <groupId>org.apache.sling</groupId>
    <artifactId>org.apache.sling.jcr.api</artifactId>
    <version>2.4.0</version>
</dependency>

How to add a dependency to Gradle

Gradle Groovy DSL: Add the following org.apache.sling : org.apache.sling.jcr.api gradle dependency to your build.gradle file:

implementation 'org.apache.sling:org.apache.sling.jcr.api:2.4.0'

Gradle Kotlin DSL: Add the following org.apache.sling : org.apache.sling.jcr.api gradle kotlin dependency to your build.gradle.kts file:

implementation("org.apache.sling:org.apache.sling.jcr.api:2.4.0")

How to add a dependency to SBT Scala

SBT Scala: Add the following org.apache.sling : org.apache.sling.jcr.api sbt scala dependency to your build.sbt file:

libraryDependencies += "org.apache.sling" % "org.apache.sling.jcr.api" % "2.4.0"