MVN

org.elder.sourcerer : sourcerer-core

Maven & Gradle

Jul 26, 2022
5 usages
74 stars

Elder Sourcerer · An opinionated framework for implementing an CQRS architecture using event sourcing

<dependency>
    <groupId>org.elder.sourcerer</groupId>
    <artifactId>sourcerer-core</artifactId>
    <version>v7.0.3</version>
</dependency>
Copy
pom.xml
Table Of Contents

Latest Version

Choose a version of org.elder.sourcerer : sourcerer-core to add to Maven or Gradle - Latest Versions:

  • Latest Stable: v7.0.3

All Versions

Choose a version of org.elder.sourcerer : sourcerer-core to add to Maven or Gradle - All Versions:

  • Version Updated
  • sourcerer-core-v7.0.3

    Jul 26, 2022
  • sourcerer-core-v7.0.2

    May 18, 2022
  • sourcerer-core-v7.0.1

    May 18, 2022
  • sourcerer-core-v6.0.0

    Oct 18, 2019
  • sourcerer-core-v5.4.0

    Oct 17, 2019
  • sourcerer-core-v5.3.1

    Aug 23, 2019
  • sourcerer-core-v5.3.0

    May 16, 2019
  • sourcerer-core-v5.2.0

    Feb 07, 2019
  • sourcerer-core-v5.1.1

    Sep 03, 2018
  • sourcerer-core-v5.1.0

    Aug 30, 2018
  • sourcerer-core-v5.0.1

    Jul 10, 2018
  • sourcerer-core-v5.0.0

    Mar 21, 2018
  • sourcerer-core-v4.3.2

    Oct 25, 2017
  • sourcerer-core-v4.3.1

    Aug 04, 2017
  • sourcerer-core-v4.3.0

    Jun 12, 2017
  • sourcerer-core-v4.2.0

    Mar 03, 2017
  • sourcerer-core-v4.1.2

    Jan 19, 2017
  • sourcerer-core-v4.1.1

    Jan 11, 2017
  • sourcerer-core-v4.1.0

    Dec 22, 2016
  • sourcerer-core-v4.0.1

    Dec 16, 2016
  • sourcerer-core-v4.0.0

    Nov 18, 2016
  • sourcerer-core-v3.0.3

    Nov 09, 2016
  • sourcerer-core-v3.0.2-3-g561d09e

    Nov 09, 2016
  • sourcerer-core-v3.0.2

    Nov 08, 2016
  • sourcerer-core-v3.0.1

    Nov 08, 2016

How to add a dependency to Maven

Add the following org.elder.sourcerer : sourcerer-core maven dependency to the pom.xml file with your favorite IDE (IntelliJ / Eclipse / Netbeans):

<dependency>
    <groupId>org.elder.sourcerer</groupId>
    <artifactId>sourcerer-core</artifactId>
    <version>v7.0.3</version>
</dependency>

How to add a dependency to Gradle

Gradle Groovy DSL: Add the following org.elder.sourcerer : sourcerer-core gradle dependency to your build.gradle file:

implementation 'org.elder.sourcerer:sourcerer-core:v7.0.3'

Gradle Kotlin DSL: Add the following org.elder.sourcerer : sourcerer-core gradle kotlin dependency to your build.gradle.kts file:

implementation("org.elder.sourcerer:sourcerer-core:v7.0.3")

How to add a dependency to SBT Scala

SBT Scala: Add the following org.elder.sourcerer : sourcerer-core sbt scala dependency to your build.sbt file:

libraryDependencies += "org.elder.sourcerer" % "sourcerer-core" % "v7.0.3"