MVN

org.opensourcebim : pluginbase

Maven & Gradle

Feb 05, 2023
30 usages
1.3k stars

PluginBase · Base project for BIMserver plugin development. Some plugins mights also need the Shared library

<dependency>
    <groupId>org.opensourcebim</groupId>
    <artifactId>pluginbase</artifactId>
    <version>1.5.184</version>
</dependency>
Copy
pom.xml
Table Of Contents

Latest Version

Choose a version of org.opensourcebim : pluginbase to add to Maven or Gradle - Latest Versions:

  • Latest Stable: 1.5.184

All Versions

Choose a version of org.opensourcebim : pluginbase to add to Maven or Gradle - All Versions:

Version Vulnerabilities Updated
2.0.x
pluginbase-2.0.0
1.5.x
pluginbase-1.5.184
pluginbase-1.5.183
pluginbase-1.5.182
pluginbase-1.5.181
pluginbase-1.5.180
pluginbase-1.5.179
pluginbase-1.5.178
pluginbase-1.5.177
pluginbase-1.5.176
pluginbase-1.5.175
pluginbase-1.5.174
pluginbase-1.5.173
pluginbase-1.5.172
pluginbase-1.5.171
pluginbase-1.5.170
pluginbase-1.5.169
pluginbase-1.5.168
pluginbase-1.5.167
pluginbase-1.5.166
pluginbase-1.5.165
pluginbase-1.5.164
pluginbase-1.5.163
pluginbase-1.5.162
pluginbase-1.5.161
pluginbase-1.5.160
pluginbase-1.5.159
pluginbase-1.5.158
pluginbase-1.5.157
pluginbase-1.5.156
pluginbase-1.5.155
pluginbase-1.5.154
pluginbase-1.5.153
pluginbase-1.5.152
pluginbase-1.5.150
pluginbase-1.5.149
pluginbase-1.5.148
pluginbase-1.5.147
pluginbase-1.5.146
pluginbase-1.5.145
pluginbase-1.5.144
pluginbase-1.5.143
pluginbase-1.5.142
pluginbase-1.5.141
pluginbase-1.5.138
pluginbase-1.5.137
pluginbase-1.5.136
pluginbase-1.5.135
pluginbase-1.5.132
pluginbase-1.5.131
pluginbase-1.5.130
pluginbase-1.5.129
pluginbase-1.5.128
pluginbase-1.5.127
pluginbase-1.5.126
pluginbase-1.5.125
pluginbase-1.5.124
pluginbase-1.5.123
pluginbase-1.5.122
pluginbase-1.5.121
pluginbase-1.5.120
pluginbase-1.5.119
pluginbase-1.5.118
pluginbase-1.5.117
pluginbase-1.5.116
pluginbase-1.5.115
pluginbase-1.5.114
pluginbase-1.5.113
pluginbase-1.5.111
pluginbase-1.5.110
pluginbase-1.5.109
pluginbase-1.5.108
pluginbase-1.5.107
pluginbase-1.5.106
pluginbase-1.5.102
pluginbase-1.5.101
pluginbase-1.5.100
pluginbase-1.5.99
pluginbase-1.5.98
pluginbase-1.5.97
pluginbase-1.5.96
pluginbase-1.5.95
pluginbase-1.5.94
pluginbase-1.5.93
pluginbase-1.5.92
pluginbase-1.5.91
pluginbase-1.5.90
pluginbase-1.5.89
pluginbase-1.5.88
pluginbase-1.5.87
pluginbase-1.5.86
pluginbase-1.5.85
pluginbase-1.5.83
pluginbase-1.5.82
pluginbase-1.5.81
pluginbase-1.5.80
pluginbase-1.5.79
pluginbase-1.5.78
pluginbase-1.5.77
pluginbase-1.5.76
pluginbase-1.5.75
pluginbase-1.5.74
pluginbase-1.5.73
pluginbase-1.5.72
pluginbase-1.5.71
pluginbase-1.5.70
pluginbase-1.5.69
pluginbase-1.5.68
pluginbase-1.5.67
pluginbase-1.5.65
pluginbase-1.5.64
pluginbase-1.5.63
pluginbase-1.5.62
pluginbase-1.5.61
pluginbase-1.5.60
pluginbase-1.5.59
pluginbase-1.5.58
pluginbase-1.5.57
pluginbase-1.5.56
pluginbase-1.5.55
pluginbase-1.5.54
pluginbase-1.5.53
pluginbase-1.5.52
pluginbase-1.5.51
pluginbase-1.5.49
pluginbase-1.5.48
pluginbase-1.5.47
pluginbase-1.5.46
pluginbase-1.5.45
pluginbase-1.5.44
pluginbase-1.5.43
pluginbase-1.5.42
pluginbase-1.5.41
pluginbase-1.5.40
pluginbase-1.5.39
pluginbase-1.5.38
pluginbase-1.5.37
pluginbase-1.5.36
pluginbase-1.5.35
pluginbase-1.5.34
pluginbase-1.5.33
pluginbase-1.5.32
pluginbase-1.5.31
pluginbase-1.5.30
pluginbase-1.5.29
pluginbase-1.5.28
pluginbase-1.5.27
pluginbase-1.5.26
pluginbase-1.5.25
pluginbase-1.5.24
pluginbase-1.5.23
pluginbase-1.5.22
pluginbase-1.5.21
pluginbase-1.5.20
pluginbase-1.5.19
pluginbase-1.5.18
pluginbase-1.5.17
pluginbase-1.5.16
pluginbase-1.5.15
pluginbase-1.5.14
pluginbase-1.5.13
pluginbase-1.5.12
pluginbase-1.5.11
pluginbase-1.5.10

How to add a dependency to Maven

Add the following org.opensourcebim : pluginbase maven dependency to the pom.xml file with your favorite IDE (IntelliJ / Eclipse / Netbeans):

<dependency>
    <groupId>org.opensourcebim</groupId>
    <artifactId>pluginbase</artifactId>
    <version>1.5.184</version>
</dependency>

How to add a dependency to Gradle

Gradle Groovy DSL: Add the following org.opensourcebim : pluginbase gradle dependency to your build.gradle file:

implementation 'org.opensourcebim:pluginbase:1.5.184'

Gradle Kotlin DSL: Add the following org.opensourcebim : pluginbase gradle kotlin dependency to your build.gradle.kts file:

implementation("org.opensourcebim:pluginbase:1.5.184")

How to add a dependency to SBT Scala

SBT Scala: Add the following org.opensourcebim : pluginbase sbt scala dependency to your build.sbt file:

libraryDependencies += "org.opensourcebim" % "pluginbase" % "1.5.184"

Advertisement

Dependencies from Group

Feb 05, 2023
30 usages
1.3k stars
Feb 05, 2023
10 usages
1.3k stars
Jan 21, 2016
9 usages
bcf
Feb 04, 2023
7 usages
2 stars
Jan 21, 2016
6 usages

Discover Dependencies

Aug 01, 2016
24 usages
18 stars
Jan 16, 2017
43 usages
5.1k stars
Aug 09, 2023
25 usages
Jun 09, 2010
25 usages
Jun 06, 2019
48 usages
2.5k stars
Jun 12, 2022
23 usages
1k stars
Oct 06, 2019
26 usages
378 stars
Oct 10, 2022
31 usages
812 stars