MVN

org.softsmithy.lib : softsmithy-lib-beans

Maven & Gradle

Dec 03, 2019
8 usages

SoftSmithy Utility Library - Beans · A JavaBeans utility library.

<dependency>
    <groupId>org.softsmithy.lib</groupId>
    <artifactId>softsmithy-lib-beans</artifactId>
    <version>2.1.1</version>
</dependency>
Copy
pom.xml
Table Of Contents

Latest Version

Choose a version of org.softsmithy.lib : softsmithy-lib-beans to add to Maven or Gradle - Latest Versions:

  • Latest Stable: 2.1.1

All Versions

Choose a version of org.softsmithy.lib : softsmithy-lib-beans to add to Maven or Gradle - All Versions:

  • Version Updated
  • softsmithy-lib-beans-2.1.1

    Dec 02, 2019
  • softsmithy-lib-beans-2.1

    Dec 01, 2019
  • softsmithy-lib-beans-2.0

    Feb 06, 2019
  • softsmithy-lib-beans-1.1.1

    Nov 06, 2018
  • softsmithy-lib-beans-1.0

    Nov 02, 2018
  • softsmithy-lib-beans-0.9

    Sep 21, 2017
  • softsmithy-lib-beans-0.8

    Sep 19, 2017
  • softsmithy-lib-beans-0.7

    Jun 29, 2017
  • softsmithy-lib-beans-0.6

    Sep 11, 2016
  • softsmithy-lib-beans-0.5

    Feb 18, 2015
  • softsmithy-lib-beans-0.4

    Oct 27, 2013
  • softsmithy-lib-beans-0.3

    Nov 27, 2012

How to add a dependency to Maven

Add the following org.softsmithy.lib : softsmithy-lib-beans maven dependency to the pom.xml file with your favorite IDE (IntelliJ / Eclipse / Netbeans):

<dependency>
    <groupId>org.softsmithy.lib</groupId>
    <artifactId>softsmithy-lib-beans</artifactId>
    <version>2.1.1</version>
</dependency>

How to add a dependency to Gradle

Gradle Groovy DSL: Add the following org.softsmithy.lib : softsmithy-lib-beans gradle dependency to your build.gradle file:

implementation 'org.softsmithy.lib:softsmithy-lib-beans:2.1.1'

Gradle Kotlin DSL: Add the following org.softsmithy.lib : softsmithy-lib-beans gradle kotlin dependency to your build.gradle.kts file:

implementation("org.softsmithy.lib:softsmithy-lib-beans:2.1.1")

How to add a dependency to SBT Scala

SBT Scala: Add the following org.softsmithy.lib : softsmithy-lib-beans sbt scala dependency to your build.sbt file:

libraryDependencies += "org.softsmithy.lib" % "softsmithy-lib-beans" % "2.1.1"