MVN

ru.yandex.qatools.allure : allure-report-plugin-api

Maven & Gradle

May 30, 2017
2 usages
715 stars

Allure Report Plugin Api

<dependency>
    <groupId>ru.yandex.qatools.allure</groupId>
    <artifactId>allure-report-plugin-api</artifactId>
    <version>1.5.4</version>
</dependency>
Copy
pom.xml
Table Of Contents

Latest Version

Choose a version of ru.yandex.qatools.allure : allure-report-plugin-api to add to Maven or Gradle - Latest Versions:

  • Latest Stable: 1.5.4
  • Latest Release Candidate: 1.4.24.RC3

All Versions

Choose a version of ru.yandex.qatools.allure : allure-report-plugin-api to add to Maven or Gradle - All Versions:

  • Version Updated
  • allure-report-plugin-api-1.5.4

    May 29, 2017
  • allure-report-plugin-api-1.5.3

    May 17, 2017
  • allure-report-plugin-api-1.5.2

    Feb 15, 2017
  • allure-report-plugin-api-1.5.1

    Feb 09, 2017
  • allure-report-plugin-api-1.5.0

    Dec 19, 2016
  • allure-report-plugin-api-1.4.24.RC3

    Jul 28, 2016
  • allure-report-plugin-api-1.4.23.HOTFIX1

    Jul 25, 2016
  • allure-report-plugin-api-1.4.24.RC2

    May 30, 2016
  • allure-report-plugin-api-1.4.24.RC1

    May 16, 2016
  • allure-report-plugin-api-1.4.23

    Mar 18, 2016
  • allure-report-plugin-api-1.4.22

    Feb 05, 2016
  • allure-report-plugin-api-1.4.21

    Feb 05, 2016
  • allure-report-plugin-api-1.5.0.RC2

    Jan 29, 2016
  • allure-report-plugin-api-1.4.20

    Jan 12, 2016
  • allure-report-plugin-api-1.5.0-RC1

    Oct 13, 2015
  • allure-report-plugin-api-1.4.19

    Sep 25, 2015
  • allure-report-plugin-api-1.4.18

    Sep 23, 2015
  • allure-report-plugin-api-1.4.17

    Aug 20, 2015
  • allure-report-plugin-api-1.4.16

    Jul 31, 2015
  • allure-report-plugin-api-1.4.15

    Jul 07, 2015
  • allure-report-plugin-api-1.4.14

    Jun 02, 2015
  • allure-report-plugin-api-1.4.13

    May 14, 2015
  • allure-report-plugin-api-1.4.12

    Apr 28, 2015
  • allure-report-plugin-api-1.4.11

    Mar 20, 2015
  • allure-report-plugin-api-1.4.10

    Feb 27, 2015

How to add a dependency to Maven

Add the following ru.yandex.qatools.allure : allure-report-plugin-api maven dependency to the pom.xml file with your favorite IDE (IntelliJ / Eclipse / Netbeans):

<dependency>
    <groupId>ru.yandex.qatools.allure</groupId>
    <artifactId>allure-report-plugin-api</artifactId>
    <version>1.5.4</version>
</dependency>

How to add a dependency to Gradle

Gradle Groovy DSL: Add the following ru.yandex.qatools.allure : allure-report-plugin-api gradle dependency to your build.gradle file:

implementation 'ru.yandex.qatools.allure:allure-report-plugin-api:1.5.4'

Gradle Kotlin DSL: Add the following ru.yandex.qatools.allure : allure-report-plugin-api gradle kotlin dependency to your build.gradle.kts file:

implementation("ru.yandex.qatools.allure:allure-report-plugin-api:1.5.4")

How to add a dependency to SBT Scala

SBT Scala: Add the following ru.yandex.qatools.allure : allure-report-plugin-api sbt scala dependency to your build.sbt file:

libraryDependencies += "ru.yandex.qatools.allure" % "allure-report-plugin-api" % "1.5.4"