MVN

org.elasticsearch : elasticsearch-spark_2.11

Maven & Gradle

Jul 05, 2017
5 usages
1.9k stars

Elasticsearch Spark (Spark 1.3+) · Elasticsearch Spark (Spark 1.3+)

<dependency>
    <groupId>org.elasticsearch</groupId>
    <artifactId>elasticsearch-spark_2.11</artifactId>
    <version>2.4.5</version>
</dependency>
Copy
pom.xml
Table Of Contents

Latest Version

Choose a version of org.elasticsearch : elasticsearch-spark_2.11 to add to Maven or Gradle - Latest Versions:

  • Latest Stable: 2.4.5
  • Latest Release Candidate: 2.2.0-rc1
  • Latest Beta: 2.2.0-beta1
  • Latest Alpha: 5.0.0-alpha4

All Versions

Choose a version of org.elasticsearch : elasticsearch-spark_2.11 to add to Maven or Gradle - All Versions:

Version Vulnerabilities Updated
5.0.x
elasticsearch-spark_2.11-5.0.0-alpha4
elasticsearch-spark_2.11-5.0.0-alpha3
elasticsearch-spark_2.11-5.0.0-alpha2
2.4.x
elasticsearch-spark_2.11-2.4.5
elasticsearch-spark_2.11-2.4.4
elasticsearch-spark_2.11-2.4.3
elasticsearch-spark_2.11-2.4.2
elasticsearch-spark_2.11-2.4.1
elasticsearch-spark_2.11-2.4.0
2.3.x
elasticsearch-spark_2.11-2.3.4
elasticsearch-spark_2.11-2.3.3
elasticsearch-spark_2.11-2.3.2
elasticsearch-spark_2.11-2.3.1
elasticsearch-spark_2.11-2.3.0
2.2.x
elasticsearch-spark_2.11-2.2.1
elasticsearch-spark_2.11-2.2.0
elasticsearch-spark_2.11-2.2.0-rc1
elasticsearch-spark_2.11-2.2.0-beta1
elasticsearch-spark_2.11-2.2.0-m1
2.1.x
elasticsearch-spark_2.11-2.1.3
elasticsearch-spark_2.11-2.1.2
elasticsearch-spark_2.11-2.1.1
elasticsearch-spark_2.11-2.1.0
elasticsearch-spark_2.11-2.1.0.rc1
elasticsearch-spark_2.11-2.1.0.Beta4

How to add a dependency to Maven

Add the following org.elasticsearch : elasticsearch-spark_2.11 maven dependency to the pom.xml file with your favorite IDE (IntelliJ / Eclipse / Netbeans):

<dependency>
    <groupId>org.elasticsearch</groupId>
    <artifactId>elasticsearch-spark_2.11</artifactId>
    <version>2.4.5</version>
</dependency>

How to add a dependency to Gradle

Gradle Groovy DSL: Add the following org.elasticsearch : elasticsearch-spark_2.11 gradle dependency to your build.gradle file:

implementation 'org.elasticsearch:elasticsearch-spark_2.11:2.4.5'

Gradle Kotlin DSL: Add the following org.elasticsearch : elasticsearch-spark_2.11 gradle kotlin dependency to your build.gradle.kts file:

implementation("org.elasticsearch:elasticsearch-spark_2.11:2.4.5")

How to add a dependency to SBT Scala

SBT Scala: Add the following org.elasticsearch : elasticsearch-spark_2.11 sbt scala dependency to your build.sbt file:

libraryDependencies += "org.elasticsearch" % "elasticsearch-spark_2.11" % "2.4.5"

Advertisement

Dependencies from Group

Aug 17, 2023
1.2k usages
68.3k stars
jna
Feb 27, 2021
66 usages
8.3k stars
Aug 17, 2023
38 usages
1.9k stars
Aug 17, 2023
36 usages
68.3k stars
Aug 17, 2023
21 usages
1.9k stars

Discover Dependencies

May 02, 2015
1 usages
8 stars
May 09, 2023
2 usages
154 stars
Apr 14, 2016
11 usages
Apr 14, 2016
1 usages
Mar 29, 2017
1 usages
Feb 24, 2023
1 usages
Feb 24, 2023
2 usages
Feb 24, 2023
3 usages