MVN

org.apache.tomcat : tomcat-jni

Maven & Gradle

Aug 23, 2023
16 usages

Interface code to the native connector

<dependency>
    <groupId>org.apache.tomcat</groupId>
    <artifactId>tomcat-jni</artifactId>
    <version>8.5.93</version>
</dependency>
Copy
pom.xml
Table Of Contents

Latest Version

Choose a version of org.apache.tomcat : tomcat-jni to add to Maven or Gradle - Latest Versions:

  • Latest Stable: 8.5.93
  • Latest Release Candidate: 8.0.0-RC10

All Versions

Choose a version of org.apache.tomcat : tomcat-jni to add to Maven or Gradle - All Versions:

Version Vulnerabilities Updated
11.0.x
tomcat-jni-11.0.0-M11
tomcat-jni-11.0.0-M10
tomcat-jni-11.0.0-M9
tomcat-jni-11.0.0-M7
tomcat-jni-11.0.0-M6
tomcat-jni-11.0.0-M5
tomcat-jni-11.0.0-M4
tomcat-jni-11.0.0-M3
tomcat-jni-11.0.0-M1
10.1.x
tomcat-jni-10.1.13
tomcat-jni-10.1.12
tomcat-jni-10.1.11
tomcat-jni-10.1.10
tomcat-jni-10.1.9
tomcat-jni-10.1.8
tomcat-jni-10.1.7
tomcat-jni-10.1.6
tomcat-jni-10.1.5
tomcat-jni-10.1.4
tomcat-jni-10.1.2
tomcat-jni-10.1.1
tomcat-jni-10.1.0
tomcat-jni-10.1.0-M17
tomcat-jni-10.1.0-M16
tomcat-jni-10.1.0-M15
tomcat-jni-10.1.0-M14
tomcat-jni-10.1.0-M12
tomcat-jni-10.1.0-M11
tomcat-jni-10.1.0-M10
tomcat-jni-10.1.0-M8
tomcat-jni-10.1.0-M7
tomcat-jni-10.1.0-M6
tomcat-jni-10.1.0-M5
tomcat-jni-10.1.0-M4
tomcat-jni-10.1.0-M2
tomcat-jni-10.1.0-M1
10.0.x
tomcat-jni-10.0.27
tomcat-jni-10.0.26
tomcat-jni-10.0.23
tomcat-jni-10.0.22
tomcat-jni-10.0.21
tomcat-jni-10.0.20
tomcat-jni-10.0.18
tomcat-jni-10.0.17
tomcat-jni-10.0.16
tomcat-jni-10.0.14
tomcat-jni-10.0.13
tomcat-jni-10.0.12
tomcat-jni-10.0.11
tomcat-jni-10.0.10
tomcat-jni-10.0.8
tomcat-jni-10.0.7
tomcat-jni-10.0.6
tomcat-jni-10.0.5
tomcat-jni-10.0.4
tomcat-jni-10.0.2
tomcat-jni-10.0.0
tomcat-jni-10.0.0-M10
tomcat-jni-10.0.0-M9
tomcat-jni-10.0.0-M8
tomcat-jni-10.0.0-M7
tomcat-jni-10.0.0-M6
tomcat-jni-10.0.0-M5
tomcat-jni-10.0.0-M4
tomcat-jni-10.0.0-M3
tomcat-jni-10.0.0-M1
9.0.x
tomcat-jni-9.0.80
tomcat-jni-9.0.79
tomcat-jni-9.0.78
tomcat-jni-9.0.76
tomcat-jni-9.0.75
tomcat-jni-9.0.74
tomcat-jni-9.0.73
tomcat-jni-9.0.72
tomcat-jni-9.0.71
tomcat-jni-9.0.70
tomcat-jni-9.0.69
tomcat-jni-9.0.68
tomcat-jni-9.0.67
tomcat-jni-9.0.65
tomcat-jni-9.0.64
tomcat-jni-9.0.63
tomcat-jni-9.0.62
tomcat-jni-9.0.60
tomcat-jni-9.0.59
tomcat-jni-9.0.58
tomcat-jni-9.0.56
tomcat-jni-9.0.55
tomcat-jni-9.0.54
tomcat-jni-9.0.53
tomcat-jni-9.0.52
tomcat-jni-9.0.50
tomcat-jni-9.0.48
tomcat-jni-9.0.46
tomcat-jni-9.0.45
tomcat-jni-9.0.44
tomcat-jni-9.0.43
tomcat-jni-9.0.41
tomcat-jni-9.0.40
tomcat-jni-9.0.39
tomcat-jni-9.0.38
tomcat-jni-9.0.37
tomcat-jni-9.0.36
tomcat-jni-9.0.35
tomcat-jni-9.0.34
tomcat-jni-9.0.33
tomcat-jni-9.0.31
tomcat-jni-9.0.30
tomcat-jni-9.0.29
tomcat-jni-9.0.27
tomcat-jni-9.0.26
tomcat-jni-9.0.24
tomcat-jni-9.0.22
tomcat-jni-9.0.21
tomcat-jni-9.0.20
tomcat-jni-9.0.19
tomcat-jni-9.0.17
tomcat-jni-9.0.16
tomcat-jni-9.0.14
tomcat-jni-9.0.13
tomcat-jni-9.0.12
tomcat-jni-9.0.11
tomcat-jni-9.0.10
tomcat-jni-9.0.8
tomcat-jni-9.0.7
tomcat-jni-9.0.6
tomcat-jni-9.0.5
tomcat-jni-9.0.4
tomcat-jni-9.0.2
tomcat-jni-9.0.1
tomcat-jni-9.0.0.M27
tomcat-jni-9.0.0.M26
tomcat-jni-9.0.0.M25
tomcat-jni-9.0.0.M22
tomcat-jni-9.0.0.M21
tomcat-jni-9.0.0.M20
tomcat-jni-9.0.0.M19
tomcat-jni-9.0.0.M18
tomcat-jni-9.0.0.M17
tomcat-jni-9.0.0.M15
tomcat-jni-9.0.0.M13
tomcat-jni-9.0.0.M11
tomcat-jni-9.0.0.M10
tomcat-jni-9.0.0.M9
tomcat-jni-9.0.0.M8
tomcat-jni-9.0.0.M6
tomcat-jni-9.0.0.M4
tomcat-jni-9.0.0.M3
tomcat-jni-9.0.0.M1
8.5.x
tomcat-jni-8.5.93
tomcat-jni-8.5.92
tomcat-jni-8.5.91
tomcat-jni-8.5.90
tomcat-jni-8.5.89
tomcat-jni-8.5.88
tomcat-jni-8.5.87
tomcat-jni-8.5.86
tomcat-jni-8.5.85
tomcat-jni-8.5.84
tomcat-jni-8.5.83
tomcat-jni-8.5.82
tomcat-jni-8.5.81
tomcat-jni-8.5.79
tomcat-jni-8.5.78
tomcat-jni-8.5.77
tomcat-jni-8.5.76
tomcat-jni-8.5.75
tomcat-jni-8.5.73
tomcat-jni-8.5.72
tomcat-jni-8.5.71
tomcat-jni-8.5.70
tomcat-jni-8.5.69
tomcat-jni-8.5.68
tomcat-jni-8.5.66
tomcat-jni-8.5.65
tomcat-jni-8.5.64
tomcat-jni-8.5.63
tomcat-jni-8.5.61
tomcat-jni-8.5.60
tomcat-jni-8.5.59
tomcat-jni-8.5.58
tomcat-jni-8.5.57
tomcat-jni-8.5.56
tomcat-jni-8.5.55
tomcat-jni-8.5.54
tomcat-jni-8.5.53
tomcat-jni-8.5.51
tomcat-jni-8.5.50
tomcat-jni-8.5.49
tomcat-jni-8.5.47
tomcat-jni-8.5.46
tomcat-jni-8.5.45
tomcat-jni-8.5.43
tomcat-jni-8.5.42
tomcat-jni-8.5.41
tomcat-jni-8.5.40
tomcat-jni-8.5.39
tomcat-jni-8.5.38
tomcat-jni-8.5.37
tomcat-jni-8.5.35
tomcat-jni-8.5.34
tomcat-jni-8.5.33
tomcat-jni-8.5.32
tomcat-jni-8.5.31
tomcat-jni-8.5.30
tomcat-jni-8.5.29
tomcat-jni-8.5.28
tomcat-jni-8.5.27
tomcat-jni-8.5.24
tomcat-jni-8.5.23
tomcat-jni-8.5.21
tomcat-jni-8.5.20
tomcat-jni-8.5.19
tomcat-jni-8.5.16
tomcat-jni-8.5.15
tomcat-jni-8.5.14
tomcat-jni-8.5.13
tomcat-jni-8.5.12
tomcat-jni-8.5.11
tomcat-jni-8.5.9
tomcat-jni-8.5.8
tomcat-jni-8.5.6
tomcat-jni-8.5.5
tomcat-jni-8.5.4
tomcat-jni-8.5.3
tomcat-jni-8.5.2
tomcat-jni-8.5.0
8.0.x
tomcat-jni-8.0.53
tomcat-jni-8.0.52
tomcat-jni-8.0.51
tomcat-jni-8.0.50
tomcat-jni-8.0.49
tomcat-jni-8.0.48
tomcat-jni-8.0.47
tomcat-jni-8.0.46
tomcat-jni-8.0.45
tomcat-jni-8.0.44
tomcat-jni-8.0.43
tomcat-jni-8.0.42
tomcat-jni-8.0.41
tomcat-jni-8.0.39
tomcat-jni-8.0.38
tomcat-jni-8.0.37
tomcat-jni-8.0.36
tomcat-jni-8.0.35
tomcat-jni-8.0.33
tomcat-jni-8.0.32
tomcat-jni-8.0.30
tomcat-jni-8.0.29
tomcat-jni-8.0.28
tomcat-jni-8.0.27
tomcat-jni-8.0.26
tomcat-jni-8.0.24
tomcat-jni-8.0.23
tomcat-jni-8.0.22
tomcat-jni-8.0.21
tomcat-jni-8.0.20
tomcat-jni-8.0.18
tomcat-jni-8.0.17
tomcat-jni-8.0.15
tomcat-jni-8.0.14
tomcat-jni-8.0.12
tomcat-jni-8.0.11
tomcat-jni-8.0.9
tomcat-jni-8.0.8
tomcat-jni-8.0.5
tomcat-jni-8.0.3
tomcat-jni-8.0.1
tomcat-jni-8.0.0-RC10
tomcat-jni-8.0.0-RC5
tomcat-jni-8.0.0-RC3
tomcat-jni-8.0.0-RC1

How to add a dependency to Maven

Add the following org.apache.tomcat : tomcat-jni maven dependency to the pom.xml file with your favorite IDE (IntelliJ / Eclipse / Netbeans):

<dependency>
    <groupId>org.apache.tomcat</groupId>
    <artifactId>tomcat-jni</artifactId>
    <version>8.5.93</version>
</dependency>

How to add a dependency to Gradle

Gradle Groovy DSL: Add the following org.apache.tomcat : tomcat-jni gradle dependency to your build.gradle file:

implementation 'org.apache.tomcat:tomcat-jni:8.5.93'

Gradle Kotlin DSL: Add the following org.apache.tomcat : tomcat-jni gradle kotlin dependency to your build.gradle.kts file:

implementation("org.apache.tomcat:tomcat-jni:8.5.93")

How to add a dependency to SBT Scala

SBT Scala: Add the following org.apache.tomcat : tomcat-jni sbt scala dependency to your build.sbt file:

libraryDependencies += "org.apache.tomcat" % "tomcat-jni" % "8.5.93"

Advertisement

Dependencies from Group

Aug 23, 2023
512 usages
Aug 23, 2023
471 usages
Aug 23, 2023
296 usages
Aug 23, 2023
272 usages
Aug 23, 2023
218 usages

Discover Dependencies

Apr 15, 2020
3 usages
Jan 30, 2021
4 usages
Mar 16, 2022
3 usages
Aug 06, 2020
7 usages
52 stars
Sep 28, 2020
2 usages
10 stars
Apr 27, 2018
6 usages
260 stars
Apr 30, 2021
10 usages
228 stars
Dec 16, 2021
4 usages
1 stars